Aller à la barre d’outils

Comment s’assurer que la version de TensorFlow soit bien au moins la 2.0 ?

DWQA QuestionsComment s’assurer que la version de TensorFlow soit bien au moins la 2.0 ?
jboscher personnel demandée il y a 6 mois

Les évolutions de TensorFlow entre la 2.x et les 1.x étant fondamentales, il est important de vérifier que la version utilisée est au moins la 2.0. Comment le vérifier ?

Avec Google Colab, c’est assez facile, on déclare préalablement que la version à utiliser est la 2.x. Pour cela, on utilise la magic command %tensorflow_version
Notez que ceci va devenir très rapidement une option car Google Colab va prochainement utiliser par défaut la 2.x

try:
# %tensorflow_version existe seulement avec Colab.
%tensorflow_version 2.x
except Exception:
pass

import tensorflow as tf

Pour vérifier la version de Tf :

print(tensorflow.__version__)

Si vous n’êtes pas dans l’environnement Colab alors après l’import, faites le test sur la version et un exit en cas d’erreur.